GHSA-pcf7-5974-vjh4

Suggest an improvement
Source
https://github.com/advisories/GHSA-pcf7-5974-vjh4
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-pcf7-5974-vjh4/GHSA-pcf7-5974-vjh4.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-pcf7-5974-vjh4
Aliases
Published
2022-05-14T02:20:16Z
Modified
2023-11-08T03:59:57.787695Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Elefant CMS Improper Input Validation
Details

apps/filemanager/handlers/upload/drop.php in Elefant CMS 2.0.3 performs a urldecode step too late in the "Cannot upload executable files" protection mechanism.

References

Affected packages

Packagist / elefant/cms

Package

Name
elefant/cms
Purl
pkg:composer/elefant/cms

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.0.4

Database specific

{
    "last_known_affected_version_range": "<= 2.0.3"
}