GHSA-pf46-gqg9-j3v3

Suggest an improvement
Source
https://github.com/advisories/GHSA-pf46-gqg9-j3v3
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2019/07/GHSA-pf46-gqg9-j3v3/GHSA-pf46-gqg9-j3v3.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-pf46-gqg9-j3v3
Aliases
Published
2019-07-05T21:08:24Z
Modified
2023-11-08T03:59:58.537264Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
Insufficient Entropy in DotNetNuke
Details

DNN (aka DotNetNuke) 9.2 through 9.2.1 incorrectly converts encryption key source values, resulting in lower than expected entropy.

References

Affected packages

NuGet / DotNetNuke.Core

Package

Name
DotNetNuke.Core
View open source insights on deps.dev
Purl
pkg:nuget/DotNetNuke.Core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
9.2.0
Fixed
9.2.2

Affected versions

9.*

9.2.0.366
9.2.1.533