GHSA-pg8m-4p8j-2p56

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-pg8m-4p8j-2p56/GHSA-pg8m-4p8j-2p56.json
Aliases
  • CVE-2021-41971
Published
2022-05-24T19:17:46Z
Modified
2022-06-21T20:32:22.457364Z
Details

Apache Superset up to and including 1.3.0 when configured with ENABLETEMPLATEPROCESSING on (disabled by default) allowed SQL injection when a malicious authenticated user sends an http request with a custom URL.

References

Affected packages

PyPI / apache-superset

apache-superset

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0
Fixed
1.3.1

Affected versions

0.*

0.34.0
0.34.1
0.35.1
0.35.2
0.36.0
0.37.0
0.37.1
0.37.2
0.38.0
0.38.1

1.*

1.0.0
1.0.1
1.1.0
1.2.0
1.3.0

Database specific

{
    "last_known_affected_version_range": "<= 1.3.0"
}