GHSA-pg98-6v7f-2xfv

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/11/GHSA-pg98-6v7f-2xfv/GHSA-pg98-6v7f-2xfv.json
Published
2022-11-23T15:44:52Z
Modified
2022-11-23T15:44:52Z
Details

sweetalert2 versions 9.17.4 and up until 10.0.0 are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions 9.0.0 - 9.17.3.

Workaround

Use a version 9.0.0 - 9.17.3 of the package until the maintainer releases a fix.

References

Affected packages

npm / sweetalert2

sweetalert2

Affected ranges

Type
SEMVER
Events
Introduced
9.17.4

Affected versions

Database specific

{
    "last_known_affected_version_range": "< 10.0.0"
}