GHSA-phhm-6pgm-mxw9

Suggest an improvement
Source
https://github.com/advisories/GHSA-phhm-6pgm-mxw9
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-phhm-6pgm-mxw9/GHSA-phhm-6pgm-mxw9.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-phhm-6pgm-mxw9
Aliases
Published
2022-05-17T02:27:14Z
Modified
2024-04-23T17:43:52.899579Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
MODX Revolution blind SQL injection
Details

MODX Revolution version 2.x - 2.5.6 is vulnerable to blind SQL injection caused by improper sanitization by the escape method resulting in authenticated user accessing database and possibly escalating privileges.

References

Affected packages

Packagist / modx/revolution

Package

Name
modx/revolution
Purl
pkg:composer/modx/revolution

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.0.0
Fixed
2.6.0

Database specific

{
    "last_known_affected_version_range": "<= 2.5.6"
}