GHSA-pjj4-jjgc-h3r8

Suggest an improvement
Source
https://github.com/advisories/GHSA-pjj4-jjgc-h3r8
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2021/03/GHSA-pjj4-jjgc-h3r8/GHSA-pjj4-jjgc-h3r8.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-pjj4-jjgc-h3r8
Published
2021-03-12T23:09:24Z
Modified
2023-04-11T01:38:13.837225Z
Summary
Authenticated remote code execution
Details

Impact

Authenticated remote code execution using plugin manager without ACL permissions.

Patches

We recommend to update to the current version 6.3.5.2. You can get the update to 6.3.5.2 regularly via the Auto-Updater or directly via the download overview.

https://www.shopware.com/en/download/#shopware-6

Workarounds

For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.

https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659

For more information

https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-03-2021

References

Affected packages

Packagist / shopware/platform

Package

Name
shopware/platform
Purl
pkg:composer/shopware/platform

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.3.5.2

Affected versions

v6.*

v6.0.0+ea2
v6.1.0-rc1
v6.1.0-rc2
v6.1.0-rc3
v6.1.0-rc4
v6.1.0
v6.1.1
v6.1.2
v6.1.3
v6.1.4
v6.1.5
v6.1.6
v6.2.0-RC1
v6.2.0
v6.2.1
v6.2.2
v6.2.3

6.*

6.3.0.0
6.3.0.1
6.3.0.2
6.3.1.0
6.3.1.1
6.3.2.0
6.3.2.1
6.3.3.0
6.3.3.1
6.3.4.0
6.3.4.1
6.3.5.0
6.3.5.1

Database specific

{
    "last_known_affected_version_range": "<= 6.3.5.1"
}