GHSA-pjm3-f4vh-3h3h

Suggest an improvement
Source
https://github.com/advisories/GHSA-pjm3-f4vh-3h3h
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/04/GHSA-pjm3-f4vh-3h3h/GHSA-pjm3-f4vh-3h3h.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-pjm3-f4vh-3h3h
Aliases
Published
2022-04-13T00:00:17Z
Modified
2024-02-16T08:23:03.745871Z
Severity
  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Stored Cross-site Scripting in Jenkins Mask Passwords Plugin
Details

Jenkins Mask Passwords Plugin 3.0 and earlier does not escape the name and description of Non-Stored Password parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

Exploitation of this vulnerability requires that parameters are listed on another page, like the \"Build With Parameters\" and \"Parameters\" pages provided by Jenkins (core), and that those pages are not hardened to prevent exploitation. Jenkins (core) has prevented exploitation of vulnerabilities of this kind on the \"Build With Parameters\" and \"Parameters\" pages since 2.44 and LTS 2.32.2 as part of the SECURITY-353 / CVE-2017-2601 fix.

References

Affected packages

Maven / org.jenkins-ci.plugins:mask-passwords

Package

Name
org.jenkins-ci.plugins:mask-passwords
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/mask-passwords

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.1

Affected versions

2.*

2.7
2.7.1
2.7.2
2.7.3
2.7.4
2.8
2.9
2.10
2.10.1
2.11.0
2.12.0
2.13

3.*

3.0