GHSA-pjqh-2jcc-5j84

Suggest an improvement
Source
https://github.com/advisories/GHSA-pjqh-2jcc-5j84
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-pjqh-2jcc-5j84/GHSA-pjqh-2jcc-5j84.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-pjqh-2jcc-5j84
Aliases
  • CVE-2017-8028
Published
2022-05-13T01:12:09Z
Modified
2024-04-10T18:57:08.806686Z
Severity
  • 8.1 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Improper Authentication in Pivotal Spring-LDAP
Details

In Pivotal Spring-LDAP versions 1.3.0 - 2.3.1, when connected to some LDAP servers, when no additional attributes are bound, and when using LDAP BindAuthenticator with org.springframework.ldap.core.support.DefaultTlsDirContextAuthenticationStrategy as the authentication strategy, and setting userSearch, authentication is allowed with an arbitrary password when the username is correct. This occurs because some LDAP vendors require an explicit operation for the LDAP bind to take effect.

References

Affected packages

Maven / org.springframework.ldap:spring-ldap-core

Package

Name
org.springframework.ldap:spring-ldap-core
View open source insights on deps.dev
Purl
pkg:maven/org.springframework.ldap/spring-ldap-core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.3.0
Fixed
2.3.2

Affected versions

1.*

1.3.0.RELEASE
1.3.1.RELEASE
1.3.2.RELEASE

2.*

2.0.0.RELEASE
2.0.1.RELEASE
2.0.2.RELEASE
2.0.3.RELEASE
2.0.4.RELEASE
2.1.0.RELEASE
2.2.0.RELEASE
2.2.1.RELEASE
2.3.0.RELEASE
2.3.1.RELEASE

Database specific

{
    "last_known_affected_version_range": "<= 2.3.1"
}