GHSA-pmv6-gf98-p3r5

Suggest an improvement
Source
https://github.com/advisories/GHSA-pmv6-gf98-p3r5
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2019/03/GHSA-pmv6-gf98-p3r5/GHSA-pmv6-gf98-p3r5.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-pmv6-gf98-p3r5
Aliases
Published
2019-03-25T16:17:18Z
Modified
2023-11-08T04:01:35.436327Z
Severity
  • 8.1 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Command Injection in kill-port
Details

Versions of kill-port prior to 1.3.2 are vulnerable to Command Injection. The package does not validate user input on the kill function. This may allow attackers to run arbitrary commands in the system if user input (such as the port number) is passed directly to the function.

Recommendation

Upgrade to version 1.3.2 or later.

References

Affected packages

npm / kill-port

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.3.2