GHSA-prc3-vjfx-vhm9

Suggest an improvement
Source
https://github.com/advisories/GHSA-prc3-vjfx-vhm9
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/07/GHSA-prc3-vjfx-vhm9/GHSA-prc3-vjfx-vhm9.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-prc3-vjfx-vhm9
Aliases
  • CVE-2022-25869
Published
2022-07-16T00:00:20Z
Modified
2023-11-08T04:08:50.091011Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Angular (deprecated package) Cross-site Scripting
Details

All versions of package angular are vulnerable to Cross-site Scripting (XSS) due to insecure page caching in the Internet Explorer browser, which allows interpolation of <textarea> elements.

NPM package angular is deprecated. Those who want to receive security updates should use the actively maintained package @angular/core.

References

Affected packages

npm / angular

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.8.3