GHSA-pwh7-92h3-mqr6

Suggest an improvement
Source
https://github.com/advisories/GHSA-pwh7-92h3-mqr6
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-pwh7-92h3-mqr6/GHSA-pwh7-92h3-mqr6.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-pwh7-92h3-mqr6
Aliases
  • CVE-2017-3586
Published
2022-05-13T01:45:42Z
Modified
2023-11-08T03:59:21.205746Z
Severity
  • 6.4 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Exposure of Sensitive Information to an Unauthorized Actor in Oracle MySQL Connectors Java
Details

Vulnerability in the MySQL Connectors component of Oracle MySQL (subcomponent: Connector/J). Supported versions that are affected are 5.1.41 and earlier. Easily "exploitable" vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Connectors. While the vulnerability is in MySQL Connectors, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of MySQL Connectors accessible data as well as unauthorized read access to a subset of MySQL Connectors accessible data. CVSS 3.0 Base Score 6.4 (Confidentiality and Integrity impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N).

References

Affected packages

Maven / mysql:mysql-connector-java

Package

Name
mysql:mysql-connector-java
View open source insights on deps.dev
Purl
pkg:maven/mysql/mysql-connector-java

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.1.42

Affected versions

2.*

2.0.14

3.*

3.0.8
3.0.10
3.1.11
3.1.12
3.1.13
3.1.14

5.*

5.0.2
5.0.3
5.0.4
5.0.5
5.0.7
5.0.8
5.1.1
5.1.2
5.1.3
5.1.4
5.1.5
5.1.6
5.1.8
5.1.9
5.1.10
5.1.11
5.1.12
5.1.13
5.1.14
5.1.15
5.1.16
5.1.17
5.1.18
5.1.19
5.1.20
5.1.21
5.1.22
5.1.23
5.1.24
5.1.25
5.1.26
5.1.27
5.1.28
5.1.29
5.1.30
5.1.31
5.1.32
5.1.33
5.1.34
5.1.35
5.1.36
5.1.37
5.1.38
5.1.39
5.1.40
5.1.41

Database specific

{
    "last_known_affected_version_range": "<= 5.1.41"
}