GHSA-pwvj-6phx-qv8c

Suggest an improvement
Source
https://github.com/advisories/GHSA-pwvj-6phx-qv8c
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-pwvj-6phx-qv8c/GHSA-pwvj-6phx-qv8c.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-pwvj-6phx-qv8c
Aliases
Published
2022-05-14T03:45:49Z
Modified
2024-02-18T05:31:07.840294Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS Calculator
Summary
CSRF vulnerability in Jenkins Translation Assistance plugin
Details

Jenkins Translation Assistance Plugin 1.15 and earlier did not require form submissions to be submitted via POST, resulting in a CSRF vulnerability allowing attackers to override localized strings displayed to all users on the current Jenkins instance if the victim is a Jenkins administrator.

References

Affected packages

Maven / org.jenkins-ci.plugins:translation

Package

Name
org.jenkins-ci.plugins:translation
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/translation

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.16

Affected versions

1.*

1.6
1.7
1.8
1.9
1.10
1.11
1.12
1.14
1.15

Database specific

{
    "last_known_affected_version_range": "<= 1.15"
}