GHSA-pxqr-8v54-m2hj

Suggest an improvement
Source
https://github.com/advisories/GHSA-pxqr-8v54-m2hj
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2018/08/GHSA-pxqr-8v54-m2hj/GHSA-pxqr-8v54-m2hj.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-pxqr-8v54-m2hj
Aliases
Published
2018-08-08T22:30:35Z
Modified
2024-02-16T08:12:30.717643Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Cross-site request forgery in rails_admin
Details

rails_admin ruby gem <v1.1.1 is vulnerable to cross-site request forgery (CSRF) attacks. Non-GET methods were not validating CSRF tokens and, as a result, an attacker could hypothetically gain access to the application administrative endpoints exposed by the gem.

References

Affected packages

RubyGems / rails_admin

Package

Name
rails_admin
Purl
pkg:gem/rails_admin

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.0.0
Fixed
1.1.1

Affected versions

1.*

1.0.0
1.1.0