GHSA-q25h-jch8-gfrp

Source
https://github.com/advisories/GHSA-q25h-jch8-gfrp
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/02/GHSA-q25h-jch8-gfrp/GHSA-q25h-jch8-gfrp.json
Aliases
  • CVE-2024-1247
Published
2024-02-09T21:30:57Z
Modified
2024-02-16T08:23:23.444798Z
Details

Concrete CMS version 9 before 9.2.5 is vulnerable to  stored XSS via the Role Name field since there is insufficient validation of administrator provided data for that field. A rogue administrator could inject malicious code into the Role Name field which might be executed when users visit the affected page. The Concrete CMS Security team scored this 2 with CVSS v3 vector AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator . Concrete versions below 9 do not include group types so they are not affected by this vulnerability.

References

Affected packages

Packagist / concrete5/concrete5

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
9.0.0RC1
Fixed
9.2.5

Affected versions

9.*

9.0.0RC1
9.0.0RC3
9.0.0RC4
9.0.0
9.0.1
9.0.2
9.1.0
9.1.1
9.1.2
9.1.3
9.2.0RC2
9.2.0
9.2.1
9.2.2
9.2.3
9.2.4