GHSA-q4q2-93pw-qwgf

Suggest an improvement
Source
https://github.com/advisories/GHSA-q4q2-93pw-qwgf
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-q4q2-93pw-qwgf/GHSA-q4q2-93pw-qwgf.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-q4q2-93pw-qwgf
Aliases
Published
2022-05-13T01:07:05Z
Modified
2024-03-04T20:48:59Z
Severity
  • 8.1 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Issuer validation regression in Spring Cloud SSO Connector
Details

Spring Cloud SSO Connector, version 2.1.2, contains a regression which disables issuer validation in resource servers that are not bound to the SSO service. In PCF deployments with multiple SSO service plans, a remote attacker can authenticate to unbound resource servers which use this version of the SSO Connector with tokens generated from another service plan.

Mitigation

Users of affected versions should apply the following mitigation: * Releases that have fixed this issue include:</p><ul><li>Spring Cloud SSO Connector: 2.1.3</li></ul> * Alternatively, you can perform <u>one</u> of the following workarounds:</p><ul><li>Bind your resource server to the SSO service plan via a service instance binding</li><li>Set “sso.connector.cloud.available=true” within your Spring application properties</li></ul>

References

Affected packages

Maven / io.pivotal.spring.cloud:spring-cloud-sso-connector

Package

Name
io.pivotal.spring.cloud:spring-cloud-sso-connector
View open source insights on deps.dev
Purl
pkg:maven/io.pivotal.spring.cloud/spring-cloud-sso-connector

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.1.2.RELEASE
Fixed
2.1.3.RELEASE

Affected versions

2.*

2.1.2.RELEASE