GHSA-q547-gmf8-8jr7

Suggest an improvement
Source
https://github.com/advisories/GHSA-q547-gmf8-8jr7
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2021/05/GHSA-q547-gmf8-8jr7/GHSA-q547-gmf8-8jr7.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-q547-gmf8-8jr7
Aliases
Published
2021-05-24T16:57:32Z
Modified
2024-05-19T02:24:09.203370Z
Severity
  • 5.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N CVSS Calculator
Summary
github.com/russellhaering/goxmldsig vulnerable to Signature Validation Bypass
Details

Impact

With a carefully crafted XML file, an attacker can completely bypass signature validation and pass off an altered file as a signed one.

Patches

A patch is available, all users of goxmldsig should upgrade to v1.1.0.

For more information

If you have any questions or comments about this advisory open an issue at https://github.com/russellhaering/goxmldsig

References

Affected packages

Go / github.com/russellhaering/goxmldsig

Package

Name
github.com/russellhaering/goxmldsig
View open source insights on deps.dev
Purl
pkg:golang/github.com/russellhaering/goxmldsig

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.1.0