GHSA-q66c-h853-gqw2

Suggest an improvement
Source
https://github.com/advisories/GHSA-q66c-h853-gqw2
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2018/10/GHSA-q66c-h853-gqw2/GHSA-q66c-h853-gqw2.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-q66c-h853-gqw2
Aliases
Published
2018-10-16T19:49:48Z
Modified
2023-11-08T03:58:28.625010Z
Severity
  • 9.1 (Critical) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N CVSS Calculator
Summary
AMQP 0-8, 0-9, 0-91, and 0-10 connection handling in Apache Qpid Java before 6.0.3 might allow remote attackers to bypass authentication
Details

The AMQP 0-8, 0-9, 0-91, and 0-10 connection handling in Apache Qpid Java before 6.0.3 might allow remote attackers to bypass authentication and consequently perform actions via vectors related to connection state logging.

References

Affected packages

Maven / org.apache.qpid:qpid-broker-plugins-amqp-0-8-protocol

Package

Name
org.apache.qpid:qpid-broker-plugins-amqp-0-8-protocol
View open source insights on deps.dev
Purl
pkg:maven/org.apache.qpid/qpid-broker-plugins-amqp-0-8-protocol

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.0.3

Affected versions

0.*

0.24
0.26
0.28
0.30
0.32

6.*

6.0.0
6.0.1
6.0.2

Maven / org.apache.qpid:qpid-broker-plugins-amqp-1-0-protocol

Package

Name
org.apache.qpid:qpid-broker-plugins-amqp-1-0-protocol
View open source insights on deps.dev
Purl
pkg:maven/org.apache.qpid/qpid-broker-plugins-amqp-1-0-protocol

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.0.3

Affected versions

0.*

0.24
0.26
0.28
0.30
0.32

6.*

6.0.0
6.0.1
6.0.2