GHSA-q77q-vx4q-xx6q

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/04/GHSA-q77q-vx4q-xx6q/GHSA-q77q-vx4q-xx6q.json
Aliases
  • CVE-2022-24891
Published
2022-04-27T21:09:46Z
Modified
2022-05-18T04:17:08.561112Z
Details

Impact

There is a potential for an XSS vulnerability in ESAPI caused by a incorrect regular expression for "onsiteURL" in the antisamy-esapi.xml configuration file that can cause URLs with the "javascript:" scheme to NOT be sanitized. See the reference below for full details.

Patches

Patched in ESAPI 2.3.0.0 and later. See important remediation details in the reference given below.

Workarounds

Manually edit your antisamy-esapi.xml configuration files to change the "onsiteURL" regular expression as per remediation instructions in the reference below.

References

Security Bulletin 8

For more information

If you have any questions or comments about this advisory: * Email one of the project co-leaders. See email addresses listed on the OWASP ESAPI wiki page, under "Leaders". * Send email to one of the two ESAPI related Google Groups listed under Where to Find More Information on ESAPI on our README.md page.

References

Affected packages

Maven / org.owasp.esapi:esapi

org.owasp.esapi:esapi

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0
Fixed
2.3.0.0

Affected versions

2.*

2.0.1
2.0GA
2.0_rc10
2.0_rc11
2.0_rc9
2.1.0
2.1.0.1
2.2.0.0
2.2.0.0-RC2
2.2.0.0-RC3
2.2.1.0
2.2.1.0-RC1
2.2.1.1
2.2.2.0
2.2.3.0
2.2.3.1

Database specific

{
    "last_known_affected_version_range": "<= 2.2.3.1"
}