GHSA-q97v-764g-r2rp

Suggest an improvement
Source
https://github.com/advisories/GHSA-q97v-764g-r2rp
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2017/11/GHSA-q97v-764g-r2rp/GHSA-q97v-764g-r2rp.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-q97v-764g-r2rp
Aliases
  • CVE-2014-9489
Published
2017-11-16T01:47:37Z
Modified
2024-02-16T07:59:55.100327Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
gollum and gollum-lib allow remote authenticated users to execute arbitrary code
Details

The gollum-grit_adapter Ruby gem dependency in gollum before 3.1.1 and the gollum-lib gem dependency in gollum-lib before 4.0.1 when the string master is in any of the wiki documents, allows remote authenticated users to execute arbitrary code via the -O or --open-files-in-pager flags.

References

Affected packages

RubyGems / gollum

Package

Name
gollum
Purl
pkg:gem/gollum

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.1.1

Affected versions

1.*

1.0.0
1.0.1
1.1.0
1.1.1
1.2.0
1.2.1
1.3.0
1.3.1
1.4.2
1.4.3

2.*

2.0.0
2.1.0
2.1.2
2.1.3
2.1.4
2.1.6
2.1.7
2.1.8
2.1.9
2.1.10
2.2.0
2.2.1
2.2.2
2.2.3
2.2.4
2.2.5
2.2.6
2.2.7
2.2.8
2.2.9
2.3.0
2.3.1
2.3.2
2.3.3
2.3.4
2.3.5
2.3.6
2.3.7
2.3.8
2.3.9
2.3.10
2.3.11
2.3.12
2.4.0
2.4.1
2.4.2
2.4.3
2.4.4
2.4.5
2.4.6
2.4.7
2.4.8
2.4.9
2.4.10
2.4.11
2.4.12
2.4.13
2.4.14
2.4.15
2.5.0
2.5.1
2.5.2
2.6.0
2.7.0

3.*

3.0.0
3.1.0

RubyGems / gollum-lib

Package

Name
gollum-lib
Purl
pkg:gem/gollum-lib

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.0.1

Affected versions

0.*

0.0.1

1.*

1.0.0
1.0.1
1.0.2
1.0.3
1.0.4
1.0.5
1.0.6
1.0.7
1.0.8
1.0.9

2.*

2.0.0

3.*

3.0.0

4.*

4.0.0