GHSA-qc7w-4567-84wv

Suggest an improvement
Source
https://github.com/advisories/GHSA-qc7w-4567-84wv
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/06/GHSA-qc7w-4567-84wv/GHSA-qc7w-4567-84wv.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-qc7w-4567-84wv
Published
2024-06-07T20:30:06Z
Modified
2024-06-07T20:45:57.138735Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Zendframework vulnerable to XXE/XEE attacks
Details

Numerous components utilizing PHP's DOMDocument, SimpleXML, and xml_parse functionality are vulnerable to two types of attacks:

  • XML eXternal Entity (XXE) Injection attacks. The above mentioned extensions are insecure by default, allowing external entities to be specified by adding a specific DOCTYPE element to XML documents and strings. By exploiting this vulnerability an application may be coerced to open arbitrary files and/or TCP connections.
  • XML Entity Expansion (XEE) vectors, leading to Denial of Service vectors. XEE attacks occur when the XML DOCTYPE declaration includes XML entity definitions that contain either recursive or circular references; this leads to CPU and memory consumption, making Denial of Service exploits trivial to implement.
References

Affected packages

Packagist / zendframework/zendframework

Package

Name
zendframework/zendframework
Purl
pkg:composer/zendframework/zendframework

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.1.0
Fixed
2.1.6

Affected versions

2.*

2.1.0
2.1.1
2.1.2
2.1.3
2.1.4
2.1.5

Packagist / zendframework/zendframework

Package

Name
zendframework/zendframework
Purl
pkg:composer/zendframework/zendframework

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.2.0
Fixed
2.2.6

Affected versions

2.*

2.2.0
2.2.1
2.2.2
2.2.3
2.2.4
2.2.5