GHSA-qf79-34j4-54m6

Suggest an improvement
Source
https://github.com/advisories/GHSA-qf79-34j4-54m6
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/04/GHSA-qf79-34j4-54m6/GHSA-qf79-34j4-54m6.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-qf79-34j4-54m6
Aliases
  • CVE-2011-4904
Published
2022-04-22T00:24:10Z
Modified
2024-01-12T21:28:28.725272Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
Typo3 Improper Access Control
Details

TYPO3 before 4.4.9 and 4.5.x before 4.5.4 does not apply proper access control on ExtDirect calls which allows remote attackers to retrieve ExtDirect endpoint services.

References

Affected packages

Packagist / typo3/cms

Package

Name
typo3/cms
Purl
pkg:composer/typo3/cms

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.9

Packagist / typo3/cms

Package

Name
typo3/cms
Purl
pkg:composer/typo3/cms

Affected ranges

Type
ECOSYSTEM
Events
Introduced
4.5.0
Fixed
4.5.4