GHSA-qfr5-wjpw-q4c4

Suggest an improvement
Source
https://github.com/advisories/GHSA-qfr5-wjpw-q4c4
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/06/GHSA-qfr5-wjpw-q4c4/GHSA-qfr5-wjpw-q4c4.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-qfr5-wjpw-q4c4
Aliases
Published
2022-06-19T00:00:21Z
Modified
2024-02-16T07:59:51.901779Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
Denial of Service in python-ldap
Details

python-ldap before 3.4.0 is vulnerable to a denial of service when ldap.schema is used for untrusted schema definitions, because of a regular expression denial of service (ReDoS) flaw in the LDAP schema parser. By sending crafted regex input, a remote authenticated attacker could exploit this vulnerability to cause a denial of service condition.

References

Affected packages

PyPI / python-ldap

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.4.0

Affected versions

2.*

2.3.13
2.4.0
2.4.1
2.4.2
2.4.3
2.4.4
2.4.5
2.4.6
2.4.7
2.4.8
2.4.9
2.4.10
2.4.12
2.4.13
2.4.14
2.4.15
2.4.16
2.4.17
2.4.18
2.4.19
2.4.20
2.4.21
2.4.22
2.4.25
2.4.26
2.4.27
2.4.28
2.4.29
2.4.30
2.4.31
2.4.32
2.4.33
2.4.35
2.4.36
2.4.37
2.4.38
2.4.39
2.4.40
2.4.41
2.4.42
2.4.43
2.4.44
2.4.45
2.5.1
2.5.2

3.*

3.0.0b1
3.0.0b2
3.0.0b3
3.0.0b4
3.0.0
3.1.0
3.2.0
3.3.0
3.3.1