GHSA-qg8p-v9q4-gh34

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2019/02/GHSA-qg8p-v9q4-gh34/GHSA-qg8p-v9q4-gh34.json
Aliases
  • CVE-2016-10541
Published
2019-02-18T23:58:29Z
Modified
2022-11-22T17:49:45Z
Details

Affected versions of shell-quote do not properly escape command line arguments, which may result in command injection if the library is used to escape user input destined for use as command line arguments.

Proof of Concept:

The following characters are not escaped properly: >,;,{,}

Bash has a neat but not well known feature known as "Bash Brace Expansion", wherein a sub-command can be executed without spaces by running it between a set of {} and using the , instead of to seperate arguments. Because of this, full command injection is possible even though it was initially thought to be impossible.

   const quote = require('shell-quote').quote;
   console.log(quote(['a;{echo,test,123,234}']));
   // Actual                    "a;{echo,test,123,234}"
   // Expected                  "a\;\{echo,test,123,234\}"
   // Functional Equivalent     "a; echo 'test' '123' '1234'"

Recommendation

Update to version 1.6.1 or later.

References

Affected packages

npm / shell-quote

shell-quote

Affected ranges

Type
SEMVER
Events
Introduced
0
Fixed
1.6.1

Affected versions