GHSA-qjqp-xr96-cj99

Suggest an improvement
Source
https://github.com/advisories/GHSA-qjqp-xr96-cj99
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/05/GHSA-qjqp-xr96-cj99/GHSA-qjqp-xr96-cj99.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-qjqp-xr96-cj99
Aliases
Published
2024-05-07T16:49:24Z
Modified
2024-06-03T17:30:48.953244Z
Severity
  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N CVSS Calculator
Summary
Trix Editor Arbitrary Code Execution Vulnerability
Details

The Trix editor, versions prior to 2.1.1, is vulnerable to arbitrary code execution when copying and pasting content from the web or other documents with markup into the editor. The vulnerability stems from improper sanitization of pasted content, allowing an attacker to embed malicious scripts which are executed within the context of the application.

Vulnerable Versions:

  • 1.x series up to and including 1.3.1
  • 2.x series up to and including 2.1.0

Fixed Versions:

  • v1.3.2
  • v2.1.1

Vector:

  • Bug 1: When copying content manipulated by a script, such as:
    document.addEventListener('copy', function(e){
      e.clipboardData.setData('text/html', '<div><noscript><div class="123</noscript>456<img src=1 onerror=alert(1)//"></div></noscript></div>');
      e.preventDefault();
    });
    

and pasting into the Trix editor, the script within the content is executed.

  • Bug 2: Similar execution occurs with content structured as:
    document.write(`copy<div data-trix-attachment="{&quot;contentType&quot;:&quot;text/html&quot;,&quot;content&quot;:&quot;&lt;img src=1 onerror=alert(101)&gt;HELLO123&quot;}"></div>me`);
    

Impact:

An attacker could exploit these vulnerabilities to execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed.

Remediation:

Update Recommendation: Users should upgrade to Trix editor version 2.1.1 or later, which incorporates proper sanitization of input from copied content.

CSP Enhancement: Additionally, enhancing the Content Security Policy (CSP) to disallow inline scripts can significantly mitigate the risk of such vulnerabilities. Set CSP policies such as script-src 'self' to ensure that only scripts hosted on the same origin are executed, and explicitly prohibit inline scripts using script-src-elem.

References:

  • https://github.com/basecamp/trix/releases/tag/v2.1.1
  • https://github.com/basecamp/trix/pull/1147
  • https://github.com/basecamp/trix/pull/1149
  • https://github.com/basecamp/trix/pull/1153

Credit: These issues were reported by security researchers loknop and pinpie.

References

Affected packages

npm / trix

Package

Affected ranges

Type
SEMVER
Events
Introduced
2.0.0
Fixed
2.1.1

npm / trix

Package

Affected ranges

Type
SEMVER
Events
Introduced
0.9.0
Fixed
1.3.2

RubyGems / actiontext

Package

Name
actiontext
Purl
pkg:gem/actiontext

Affected ranges

Type
ECOSYSTEM
Events
Introduced
7.0.0.alpha1
Fixed
7.0.8.3

Affected versions

7.*

7.0.0.alpha1
7.0.0.alpha2
7.0.0.rc1
7.0.0.rc2
7.0.0.rc3
7.0.0
7.0.1
7.0.2
7.0.2.1
7.0.2.2
7.0.2.3
7.0.2.4
7.0.3
7.0.3.1
7.0.4
7.0.4.1
7.0.4.2
7.0.4.3
7.0.5
7.0.5.1
7.0.6
7.0.7
7.0.7.1
7.0.7.2
7.0.8
7.0.8.1
7.0.8.2

RubyGems / actiontext

Package

Name
actiontext
Purl
pkg:gem/actiontext

Affected ranges

Type
ECOSYSTEM
Events
Introduced
7.1.0.beta1
Fixed
7.1.3.3

Affected versions

7.*

7.1.0.beta1
7.1.0.rc1
7.1.0.rc2
7.1.0
7.1.1
7.1.2
7.1.3
7.1.3.1
7.1.3.2