GHSA-qjvm-p5vg-437c

Source
https://github.com/advisories/GHSA-qjvm-p5vg-437c
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/04/GHSA-qjvm-p5vg-437c/GHSA-qjvm-p5vg-437c.json
Aliases
  • CVE-2024-23115
Published
2024-04-02T00:30:46Z
Modified
2024-04-02T14:58:49.901314Z
Details

Centreon updateGroups SQL Injection Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Centreon. Authentication is required to exploit this vulnerability.

The specific flaw exists within the updateGroups function. The issue results from the lack of proper validation of a user-supplied string before using it to construct SQL queries. An attacker can leverage this vulnerability to execute code in the context of the service account. Was ZDI-CAN-22295.

References

Affected packages

Packagist / centreon/centreon

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0The exact introduced commit is unknown
Fixed
22.10.15