GHSA-qmw8-x364-xxxm

Suggest an improvement
Source
https://github.com/advisories/GHSA-qmw8-x364-xxxm
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/06/GHSA-qmw8-x364-xxxm/GHSA-qmw8-x364-xxxm.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-qmw8-x364-xxxm
Aliases
Published
2023-06-10T09:30:16Z
Modified
2024-02-16T08:24:46.188398Z
Severity
  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Teampass Cross-site Scripting vulnerability
Details

In versions of nilsteampassnet/teampass prior to 3.0.9 some user input was not properly sanitized which may have lead to stored cross-site scripting (XSS) vectors in the application.

References

Affected packages

Packagist / nilsteampassnet/teampass

Package

Name
nilsteampassnet/teampass
Purl
pkg:composer/nilsteampassnet/teampass

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.0.9

Affected versions

2.*

2.1.21
2.1.26
2.1.27

3.*

3.0.0
3.0.0.10
3.0.0.11