GHSA-qpgw-2c72-4c89

Suggest an improvement
Source
https://github.com/advisories/GHSA-qpgw-2c72-4c89
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2021/01/GHSA-qpgw-2c72-4c89/GHSA-qpgw-2c72-4c89.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-qpgw-2c72-4c89
Aliases
Published
2021-01-19T20:50:38Z
Modified
2024-02-16T08:20:49.847664Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
Mautic users able to download any files from server using filemanager
Details

Impact

Mautic versions 1.0.0 - 2.11.0 are vulnerable to allowing any authorized Mautic user session (must be logged into Mautic) to use the Filemanager to download any file from the server that the web user has access to.

Patches

Update to 2.12.0 or later.

Workarounds

None

For more information

If you have any questions or comments about this advisory: * Email us at security@mautic.org

References

Affected packages

Packagist / mautic/core

Package

Name
mautic/core
Purl
pkg:composer/mautic/core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.0.0
Fixed
2.12.0

Affected versions

1.*

1.0.0
1.0.1
1.0.2
1.0.3
1.0.4
1.0.5
1.1.0
1.1.1
1.1.2
1.1.3
1.2.0-beta1
1.2.0
1.2.1
1.2.2
1.2.3
1.2.4
1.3.0
1.3.1
1.4.0
1.4.1

2.*

2.0.0
2.0.1
2.1.0
2.1.1
2.2.0
2.2.1
2.3.0
2.4.0
2.5.0
2.5.1
2.6.0
2.6.1
2.7.0
2.7.1
2.8.0
2.8.1
2.8.2
2.9.0-beta
2.9.0
2.9.1
2.9.2
2.10.0-beta
2.10.0
2.10.1
2.11.0-beta
2.11.0
2.12.0-beta