GHSA-qrh2-mh97-pw8p

Suggest an improvement
Source
https://github.com/advisories/GHSA-qrh2-mh97-pw8p
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-qrh2-mh97-pw8p/GHSA-qrh2-mh97-pw8p.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-qrh2-mh97-pw8p
Aliases
  • CVE-2019-1003076
Published
2022-05-13T01:25:43Z
Modified
2024-02-16T08:09:25.133464Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N CVSS Calculator
Summary
CSRF vulnerability in Jenkins Audit to Database Plugin
Details

A cross-site request forgery vulnerability in Jenkins Audit to Database Plugin in the DbAuditPublisherDescriptorImpl#doTestJdbcConnection form validation method allows attackers to initiate a connection to an attacker-specified server.

References

Affected packages

Maven / org.jenkins-ci.plugins:audit2db

Package

Name
org.jenkins-ci.plugins:audit2db
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/audit2db

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
0.5

Affected versions

0.*

0.4
0.5