GHSA-qwqh-hm9m-p5hr

Suggest an improvement
Source
https://github.com/advisories/GHSA-qwqh-hm9m-p5hr
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/03/GHSA-qwqh-hm9m-p5hr/GHSA-qwqh-hm9m-p5hr.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-qwqh-hm9m-p5hr
Aliases
Published
2023-03-30T06:30:25Z
Modified
2023-11-08T04:11:58.626392Z
Severity
  • 5.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L CVSS Calculator
Summary
angular vulnerable to regular expression denial of service via the <input type="url"> element
Details

All versions of the package angular are vulnerable to Regular Expression Denial of Service (ReDoS) via the <input type="url"> element due to the usage of an insecure regular expression in the input[url] functionality. Exploiting this vulnerability is possible by a large carefully-crafted input, which can result in catastrophic backtracking.

References

Affected packages

npm / angular

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.8.3