GHSA-r2f6-6928-fh8f

Suggest an improvement
Source
https://github.com/advisories/GHSA-r2f6-6928-fh8f
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/08/GHSA-r2f6-6928-fh8f/GHSA-r2f6-6928-fh8f.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-r2f6-6928-fh8f
Aliases
Published
2023-08-17T15:30:23Z
Modified
2024-02-16T08:20:11.278991Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
Apache Airflow Spark Provider Improper Input Validation vulnerability
Details

Apache Airflow Spark Provider, versions before 4.1.3, is affected by a vulnerability that allows an attacker to pass in malicious parameters when establishing a connection giving an opportunity to read files on the Airflow server. It is recommended to upgrade to a version that is not affected.

References

Affected packages

PyPI / apache-airflow-providers-apache-spark

Package

Name
apache-airflow-providers-apache-spark
View open source insights on deps.dev
Purl
pkg:pypi/apache-airflow-providers-apache-spark

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.1.3

Affected versions

1.*

1.0.0b1
1.0.0b2
1.0.0rc1
1.0.0
1.0.1rc1
1.0.1
1.0.2rc1
1.0.2
1.0.3rc1
1.0.3

2.*

2.0.0rc1
2.0.0rc2
2.0.0
2.0.1rc1
2.0.1
2.0.2rc1
2.0.2
2.0.3rc1
2.0.3
2.1.0rc1
2.1.0rc2
2.1.0
2.1.1rc1
2.1.1
2.1.2rc1
2.1.2
2.1.3rc1
2.1.3

3.*

3.0.0rc1
3.0.0rc2
3.0.0

4.*

4.0.0rc1
4.0.0
4.0.1rc1
4.0.1
4.1.0rc1
4.1.0rc2
4.1.0
4.1.1rc1
4.1.1
4.1.2rc1
4.1.2
4.1.3rc1