GHSA-r58x-wjg8-63m9

Suggest an improvement
Source
https://github.com/advisories/GHSA-r58x-wjg8-63m9
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/01/GHSA-r58x-wjg8-63m9/GHSA-r58x-wjg8-63m9.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-r58x-wjg8-63m9
Aliases
Related
Published
2022-01-08T00:40:30Z
Modified
2024-05-15T06:49:27.368463Z
Summary
Denial of Service in Apache James
Details

In Apache James, using Jazzer fuzzer, we identified that an IMAP user can craft IMAP LIST commands to orchestrate a Denial Of Service using a vulnerable Regular expression. This affected Apache James prior to 3.6.1 We recommend upgrading to Apache James 3.6.1 or higher , which enforce the use of RE2J regular expression engine to execute regex in linear time without back-tracking.

References

Affected packages

Maven / org.apache.james:james-server

Package

Name
org.apache.james:james-server
View open source insights on deps.dev
Purl
pkg:maven/org.apache.james/james-server

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.1.0
Fixed
3.6.1

Affected versions

3.*

3.1.0
3.2.0
3.3.0
3.4.0
3.5.0
3.6.0