GHSA-rc94-7v55-wmg6

Suggest an improvement
Source
https://github.com/advisories/GHSA-rc94-7v55-wmg6
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-rc94-7v55-wmg6/GHSA-rc94-7v55-wmg6.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-rc94-7v55-wmg6
Aliases
Published
2022-05-14T02:01:19Z
Modified
2024-02-16T08:21:51.946255Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Subrion CMS CSRF Vulnerability
Details

There are CSRF vulnerabilities in Subrion CMS 4.1.x through 4.1.5, and before 4.2.0, because of a logic error. Although there is functionality to detect CSRF, it is called too late in the ia.core.php code, allowing (for example) an attack against the query parameter to panel/database.

References

Affected packages

Packagist / intelliants/subrion

Package

Name
intelliants/subrion
Purl
pkg:composer/intelliants/subrion

Affected ranges

Type
ECOSYSTEM
Events
Introduced
4.1
Fixed
4.2.0

Affected versions

v4.*

v4.1.0
v4.1.1
v4.1.2
v4.1.3
v4.1.4
v4.1.5