GHSA-rf7h-9m85-535v

Suggest an improvement
Source
https://github.com/advisories/GHSA-rf7h-9m85-535v
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-rf7h-9m85-535v/GHSA-rf7h-9m85-535v.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-rf7h-9m85-535v
Aliases
Published
2022-05-14T02:21:29Z
Modified
2024-02-16T08:03:57.378758Z
Severity
  • 4.2 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N CVSS Calculator
Summary
Jenkins Publisher Over CIFS Plugin confused deputy vulnerability
Details

A confused deputy vulnerability exists in Jenkins Publisher Over CIFS Plugin 0.10 and earlier in CifsPublisherPluginDescriptor.java that allows attackers to have Jenkins connect to an attacker specified CIFS server with attacker specified credentials. Additionally, this form validation method did not require POST requests, resulting in a CSRF vulnerability. As of version 0.11, this form validation method requires POST requests and Overall/Administer permissions.

References

Affected packages

Maven / org.jenkins-ci.plugins:publish-over-cifs

Package

Name
org.jenkins-ci.plugins:publish-over-cifs
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/publish-over-cifs

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.11

Affected versions

0.*

0.2
0.3
0.5
0.6
0.9
0.10

Database specific

{
    "last_known_affected_version_range": "<= 0.10"
}