GHSA-rfqq-wq6w-72jm

Suggest an improvement
Source
https://github.com/advisories/GHSA-rfqq-wq6w-72jm
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/05/GHSA-rfqq-wq6w-72jm/GHSA-rfqq-wq6w-72jm.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-rfqq-wq6w-72jm
Aliases
Published
2024-05-16T09:33:08Z
Modified
2024-05-19T02:24:47.530915Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
MLflow has a Local File Read/Path Traversal bypass
Details

A path traversal vulnerability exists in mlflow/mlflow version 2.11.0, identified as a bypass for the previously addressed CVE-2023-6909. The vulnerability arises from the application's handling of artifact URLs, where a '#' character can be used to insert a path into the fragment, effectively skipping validation. This allows an attacker to construct a URL that, when processed, ignores the protocol scheme and uses the provided path for filesystem access. As a result, an attacker can read arbitrary files, including sensitive information such as SSH and cloud keys, by exploiting the way the application converts the URL into a filesystem path. The issue stems from insufficient validation of the fragment portion of the URL, leading to arbitrary file read through path traversal.

References

Affected packages

PyPI / mlflow

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.9.2
Fixed
2.12.1

Affected versions

2.*

2.9.2
2.10.0
2.10.1
2.10.2
2.11.0
2.11.1
2.11.2
2.11.3
2.12.0