GHSA-rj7m-2p3g-fjxg

Suggest an improvement
Source
https://github.com/advisories/GHSA-rj7m-2p3g-fjxg
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/02/GHSA-rj7m-2p3g-fjxg/GHSA-rj7m-2p3g-fjxg.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-rj7m-2p3g-fjxg
Aliases
  • CVE-2022-25855
Published
2023-02-06T06:30:25Z
Modified
2023-11-08T04:08:49.440936Z
Severity
  • 7.8 (High) CVSS_V3 - CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
create-choo-app3 is vulnerable to Command Injection via the devInstall function
Details

All versions of the package create-choo-app3 are vulnerable to Command Injection via the devInstall function due to improper user-input sanitization.

References

Affected packages

npm / create-choo-app3

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.12.3