GHSA-rm23-6mwv-8q9q

Suggest an improvement
Source
https://github.com/advisories/GHSA-rm23-6mwv-8q9q
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/07/GHSA-rm23-6mwv-8q9q/GHSA-rm23-6mwv-8q9q.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-rm23-6mwv-8q9q
Aliases
  • CVE-2022-34793
Published
2022-07-01T00:01:07Z
Modified
2023-11-08T04:09:47.435802Z
Severity
  • 7.1 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N CVSS Calculator
Summary
XML External Entity Reference in Jenkins Recipe Plugin
Details

Jenkins Recipe Plugin 1.2 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.

References

Affected packages

Maven / org.jenkins-ci.plugins:recipe

Package

Name
org.jenkins-ci.plugins:recipe
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/recipe

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.2

Affected versions

1.*

1.0
1.1
1.2