GHSA-rp8m-h266-53jh

Suggest an improvement
Source
https://github.com/advisories/GHSA-rp8m-h266-53jh
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-rp8m-h266-53jh/GHSA-rp8m-h266-53jh.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-rp8m-h266-53jh
Aliases
  • CVE-2019-15795
Published
2022-05-24T17:12:47Z
Modified
2023-11-08T04:01:15.311543Z
Severity
  • 4.7 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
python-apt Flawed Package Integrity Check
Details

python-apt only checks the MD5 sums of downloaded files in Version.fetch_binary() and Version.fetch_source() of apt/package.py in version 1.9.0ubuntu1 and earlier. This allows a man-in-the-middle attack which could potentially be used to install altered packages and has been fixed in versions 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, and 0.8.3ubuntu7.5.

References

Affected packages

PyPI / python-apt

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.8.3ubuntu7.5

PyPI / python-apt

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0.9.0
Fixed
0.9.3.5ubuntu3

PyPI / python-apt

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.0.0
Fixed
1.1.0

PyPI / python-apt

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.2.0
Fixed
1.6.5ubuntu0.1

PyPI / python-apt

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.7.0
Fixed
1.9.0ubuntu1.2