GHSA-rv25-9wgj-xg75

Suggest an improvement
Source
https://github.com/advisories/GHSA-rv25-9wgj-xg75
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-rv25-9wgj-xg75/GHSA-rv25-9wgj-xg75.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-rv25-9wgj-xg75
Aliases
Published
2022-05-14T02:57:27Z
Modified
2024-02-23T21:13:13.853935Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Apache Airflow Reflected Cross-site Scripting vulnerability in 404 Endpoint
Details

It was noticed an XSS in certain 404 pages that could be exploited to perform an XSS attack. Chrome will detect this as a reflected XSS attempt and prevent the page from loading. However Firefox and other browsers don't, and are vulnerable to this attack. Mitigation: The fix for this is to upgrade to Apache Airflow 1.9.0 or above.

References

Affected packages

PyPI / apache-airflow

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.9.0

Affected versions

1.*

1.8.1
1.8.2rc1
1.8.2