GHSA-v3hp-mcj5-pg39

Source
https://github.com/advisories/GHSA-v3hp-mcj5-pg39
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/03/GHSA-v3hp-mcj5-pg39/GHSA-v3hp-mcj5-pg39.json
Aliases
Published
2023-03-30T03:30:38Z
Modified
2023-12-06T01:02:45.642134Z
Summary
HashiCorp Vault’s Microsoft SQL Database Storage Backend Vulnerable to SQL Injection Via Configuration File
Details

HashiCorp Vault and Vault Enterprise versions 0.8.0 until 1.13.1 are vulnerable to an SQL injection attack when using the Microsoft SQL (MSSQL) Database Storage Backend. When configuring the MSSQL plugin, certain parameters are required to establish a connection (schema, database, and table) are not sanitized when passed to the user-provided MSSQL database. A privileged attacker with the ability to write arbitrary data to Vault's configuration may modify these parameters to execute a malicious SQL command when the Vault configuration is applied. This issue is fixed in versions 1.13.1, 1.12.5, and 1.11.9.

References

Affected packages

Go / github.com/hashicorp/vault

Affected ranges

Type
SEMVER
Events
Introduced
0.8.0
Fixed
1.11.9

Go / github.com/hashicorp/vault

Affected ranges

Type
SEMVER
Events
Introduced
1.12.0
Fixed
1.12.5

Go / github.com/hashicorp/vault

Affected ranges

Type
SEMVER
Events
Introduced
1.13.0
Fixed
1.13.1