GHSA-v5rq-w2xm-7g5f

Suggest an improvement
Source
https://github.com/advisories/GHSA-v5rq-w2xm-7g5f
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-v5rq-w2xm-7g5f/GHSA-v5rq-w2xm-7g5f.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-v5rq-w2xm-7g5f
Aliases
  • CVE-2019-2435
Published
2022-05-13T01:22:02Z
Modified
2024-02-20T05:22:07.435798Z
Severity
  • 8.1 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N CVSS Calculator
Summary
Improper Access Control in MySQL Connector Python
Details

Vulnerability in the MySQL Connectors component of Oracle MySQL (subcomponent: Connector/Python). Supported versions that are affected are 8.0.13 and prior and 2.1.8 and prior. Easily exploitable vulnerability allows unauthenticated attacker with network access via TLS to compromise MySQL Connectors. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in unauthorized creation, deletion or modification access to critical data or all MySQL Connectors accessible data as well as unauthorized access to critical data or complete access to all MySQL Connectors accessible data.

References

Affected packages

PyPI / mysql-connector-python

Package

Name
mysql-connector-python
View open source insights on deps.dev
Purl
pkg:pypi/mysql-connector-python

Affected ranges

Type
ECOSYSTEM
Events
Introduced
8.0.0
Fixed
8.0.19

Affected versions

8.*

8.0.5
8.0.6
8.0.11
8.0.12
8.0.13
8.0.14
8.0.15
8.0.16
8.0.17
8.0.18

Database specific

{
    "last_known_affected_version_range": "<= 8.0.13"
}

PyPI / mysql-connector-python

Package

Name
mysql-connector-python
View open source insights on deps.dev
Purl
pkg:pypi/mysql-connector-python

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.1.0
Last affected
2.1.8