GHSA-v6gf-x8fp-532v

Suggest an improvement
Source
https://github.com/advisories/GHSA-v6gf-x8fp-532v
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-v6gf-x8fp-532v/GHSA-v6gf-x8fp-532v.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-v6gf-x8fp-532v
Aliases
  • CVE-2015-8797
Published
2022-05-17T03:58:49Z
Modified
2023-11-08T03:58:03.073502Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Improper Neutralization of Input During Web Page Generation in Apache Solr
Details

Cross-site scripting (XSS) vulnerability in webapp/web/js/scripts/plugins.js in the stats page in the Admin UI in Apache Solr before 5.3.1 allows remote attackers to inject arbitrary web script or HTML via the entry parameter to a plugins/cache URI.

References

Affected packages

Maven / org.apache.solr:solr-core

Package

Name
org.apache.solr:solr-core
View open source insights on deps.dev
Purl
pkg:maven/org.apache.solr/solr-core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.3.1

Affected versions

1.*

1.3.0
1.4.0
1.4.1

3.*

3.1.0
3.2.0
3.3.0
3.4.0
3.5.0
3.6.0
3.6.1
3.6.2

4.*

4.0.0-ALPHA
4.0.0-BETA
4.0.0
4.1.0
4.2.0
4.2.1
4.3.0
4.3.1
4.4.0
4.5.0
4.5.1
4.6.0
4.6.1
4.7.0
4.7.1
4.7.2
4.8.0
4.8.1
4.9.0
4.9.1
4.10.0
4.10.1
4.10.2
4.10.3
4.10.4

5.*

5.0.0
5.1.0
5.2.0
5.2.1
5.3.0

Database specific

{
    "last_known_affected_version_range": "<= 5.3.0"
}