GHSA-v6q8-8wgx-8hm7

Suggest an improvement
Source
https://github.com/advisories/GHSA-v6q8-8wgx-8hm7
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-v6q8-8wgx-8hm7/GHSA-v6q8-8wgx-8hm7.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-v6q8-8wgx-8hm7
Aliases
Published
2022-05-14T01:38:22Z
Modified
2024-02-16T08:07:38.369220Z
Severity
  • 4.8 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Croogo vulnerable to XSS in title field
Details

A stored-self XSS exists in Croogo through v3.0.5, allowing an attacker to execute HTML or JavaScript code in a vulnerable Title field to /admin/blocks/blocks/edit/8.

References

Affected packages

Packagist / croogo/croogo

Package

Name
croogo/croogo
Purl
pkg:composer/croogo/croogo

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.0.7

Affected versions

v2.*

v2.0.0
v2.1.0
v2.1.1
v2.1.2
v2.2.0
v2.2.1
v2.2.2
v2.2.3
v2.2.4
v2.3.0
v2.3.1
v2.3.2

2.*

2.3.3

3.*

3.0.0-alpha.1
3.0.0-alpha.2
3.0.0-alpha.3
3.0.0-alpha.4
3.0.0-beta.1
3.0.0
3.0.1
3.0.2
3.0.3
3.0.4
3.0.5
3.0.6

Database specific

{
    "last_known_affected_version_range": "<= 3.0.5"
}