GHSA-v9q6-fm48-rx74

Suggest an improvement
Source
https://github.com/advisories/GHSA-v9q6-fm48-rx74
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/06/GHSA-v9q6-fm48-rx74/GHSA-v9q6-fm48-rx74.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-v9q6-fm48-rx74
Aliases
  • CVE-2024-3408
Published
2024-06-06T21:30:37Z
Modified
2024-06-06T23:27:23.109294Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Authentication bypass in dtale
Details

man-group/dtale version 3.10.0 is vulnerable to an authentication bypass and remote code execution (RCE) due to improper input validation. The vulnerability arises from a hardcoded SECRET_KEY in the flask configuration, allowing attackers to forge a session cookie if authentication is enabled. Additionally, the application fails to properly restrict custom filter queries, enabling attackers to execute arbitrary code on the server by bypassing the restriction on the /update-settings endpoint, even when enable_custom_filters is not enabled. This vulnerability allows attackers to bypass authentication mechanisms and execute remote code on the server.

References

Affected packages

PyPI / dtale

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
3.10.0

Affected versions

1.*

1.0.0
1.1.1
1.2.0
1.3.7
1.4.1
1.5.1
1.6.1
1.6.2
1.6.3
1.6.4
1.6.5
1.6.6
1.6.7
1.6.8
1.6.9
1.6.10
1.7.0
1.7.1
1.7.2
1.7.3
1.7.4
1.7.5
1.7.6
1.7.7
1.7.8
1.7.9
1.7.10
1.7.11
1.7.12
1.7.13
1.7.14
1.7.15
1.8.0
1.8.1
1.8.3
1.8.4
1.8.6
1.8.7
1.8.8
1.8.9
1.8.10
1.8.11
1.8.12
1.8.13
1.8.14
1.8.15
1.8.16
1.8.17
1.8.18
1.8.19
1.9.0
1.9.1
1.9.2
1.10.0
1.11.0
1.12.1
1.13.0
1.14.1
1.15.2
1.16.0
1.17.0
1.18.2
1.19.2
1.20.0
1.21.1
1.22.0
1.22.1
1.23.0
1.24.0
1.25.0
1.26.0
1.27.0
1.28.0
1.28.1
1.29.0
1.29.1
1.30.0
1.31.0
1.32.0
1.32.1
1.33.0
1.33.1
1.34.0
1.35.0
1.36.0
1.37.0
1.37.1
1.38.0
1.39.0
1.40.0
1.40.1
1.40.2
1.41.0
1.41.1
1.42.0
1.42.1
1.43.0
1.44.0
1.44.1
1.45.0
1.46.0
1.47.0
1.48.0
1.49.0
1.50.0
1.50.1
1.51.0
1.52.0
1.53.0
1.54.0
1.54.1
1.55.0
1.56.0
1.57.0
1.58.1
1.58.2
1.58.3
1.59.0
1.59.1
1.60.1
1.60.2
1.61.0
1.61.1

2.*

2.0.0
2.1.0
2.1.2
2.2.0
2.3.0
2.4.0
2.5.1
2.6.0
2.7.1
2.8.0
2.8.1
2.9.0
2.9.1
2.10.0
2.11.0
2.12.0
2.12.1
2.12.2
2.12.3
2.13.0
2.14.0
2.14.1
2.15.0
2.15.2
2.16.0

3.*

3.0.0
3.1.0
3.1.6
3.1.7
3.2.0
3.3.0
3.4.0
3.5.0
3.6.0
3.7.0
3.8.0
3.8.1
3.9.0
3.10.0