GHSA-v9vj-9pxv-mr2w

Suggest an improvement
Source
https://github.com/advisories/GHSA-v9vj-9pxv-mr2w
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/10/GHSA-v9vj-9pxv-mr2w/GHSA-v9vj-9pxv-mr2w.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-v9vj-9pxv-mr2w
Aliases
Related
Published
2023-10-20T00:30:24Z
Modified
2024-02-16T08:18:57.765447Z
Summary
mycli has Inadequate Encryption Strength
Details

Inadequate encryption strength in mycli 1.27.0 allows attackers to view sensitive information via /mycli/config.py.

References

Affected packages

PyPI / mycli

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.27.0

Affected versions

0.*

0.0.0

1.*

1.0.0
1.0.1
1.1.1
1.2.0
1.3.0
1.4.0
1.5.0
1.5.1
1.5.2
1.6.0
1.7.0
1.7.1
1.8.0
1.8.1
1.9.0
1.10.0
1.11.0
1.12.0
1.12.1
1.13.0
1.13.1
1.14.0
1.15.0
1.16.0
1.17.0
1.18.0
1.18.1
1.18.2
1.19.0
1.20.0
1.20.1
1.21.0
1.21.1
1.22.0
1.22.1
1.22.2
1.23.0
1.23.1
1.23.2
1.24.0
1.24.1
1.24.2
1.24.3
1.24.4
1.25.0
1.26.0
1.26.1
1.27.0