GHSA-vc29-mvwv-wpcq

Suggest an improvement
Source
https://github.com/advisories/GHSA-vc29-mvwv-wpcq
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-vc29-mvwv-wpcq/GHSA-vc29-mvwv-wpcq.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-vc29-mvwv-wpcq
Aliases
  • CVE-2006-4067
Published
2022-05-01T07:15:05Z
Modified
2023-11-08T03:56:46.968349Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:H CVSS Calculator
Summary
Cross-site scripting (XSS) vulnerability in CakePHP
Details

Cross-site scripting (XSS) vulnerability in cake/libs/error.php in CakePHP before 1.1.7.3363 allows remote attackers to inject arbitrary web script or HTML via the URL, which is reflected back in a 404 (\"Not Found\") error page. NOTE: some of these details are obtained from third party information.

References

Affected packages

Packagist / cakephp/cakephp

Package

Name
cakephp/cakephp
Purl
pkg:composer/cakephp/cakephp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.0.1.2708
Fixed
1.1.7.3363

Database specific

{
    "last_known_affected_version_range": "<= 1.1.6.3264"
}