GHSA-vc4f-2g7f-pmqr

Suggest an improvement
Source
https://github.com/advisories/GHSA-vc4f-2g7f-pmqr
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-vc4f-2g7f-pmqr/GHSA-vc4f-2g7f-pmqr.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-vc4f-2g7f-pmqr
Aliases
Published
2022-05-24T17:24:15Z
Modified
2024-02-16T08:14:36.986001Z
Severity
  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
MunkiReport Cross-Site Scripting (XSS) Filter Bypass On Comment
Details

A Cross-Site Scripting (XSS) vulnerability in the comment module before 4.0 for MunkiReport allows remote attackers to inject arbitrary web script or HTML by posting a new comment.

References

Affected packages

Packagist / munkireport/comment

Package

Name
munkireport/comment
Purl
pkg:composer/munkireport/comment

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.1

Affected versions

v1.*

v1.1

v2.*

v2.0
v2.1
v2.2

v3.*

v3.0
v3.1
v3.2

v4.*

v4.0

Packagist / munkireport/managedinstalls

Package

Name
munkireport/managedinstalls
Purl
pkg:composer/munkireport/managedinstalls

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.6

Affected versions

V2.*

V2.3

v1.*

v1.1
v1.2

v2.*

v2.0
v2.1
v2.2
v2.4
v2.5

Packagist / munkireport/munkireport

Package

Name
munkireport/munkireport
Purl
pkg:composer/munkireport/munkireport

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.5.3
Fixed
5.6.3

Affected versions

3.*

3.0
3.1

v3.*

v3.2

v4.*

v4.0

v5.*

v5.0b1
v5.0
v5.1