GHSA-vc5r-xfc4-4x22

Suggest an improvement
Source
https://github.com/advisories/GHSA-vc5r-xfc4-4x22
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/03/GHSA-vc5r-xfc4-4x22/GHSA-vc5r-xfc4-4x22.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-vc5r-xfc4-4x22
Aliases
Published
2022-03-25T00:00:33Z
Modified
2023-12-06T01:01:49.853929Z
Severity
  • 4.8 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Cross-site Scripting in Pimcore Datahub
Details

Pimcore Datahub prior to 1.2.4 is vulnerable to stored cross-site scripting. An admin user accessing Datahub triggers the attack, which may result in the user's cookie being stolen.

References

Affected packages

Packagist / pimcore/data-hub

Package

Name
pimcore/data-hub
Purl
pkg:composer/pimcore/data-hub

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.2.4

Affected versions

v0.*

v0.1
v0.2
v0.3
v0.4
v0.5
v0.6
v0.6.1
v0.6.2
v0.6.3
v0.7
v0.8

v1.*

v1.0
v1.0.1
v1.0.2
v1.0.3
v1.0.4
v1.0.5
v1.0.6
v1.0.7
v1.0.8
v1.0.9
v1.0.10
v1.0.11
v1.1.0
v1.1.1
v1.1.2
v1.1.3
v1.1.4
v1.1.6
v1.1.7
v1.2.0
v1.2.1
v1.2.2
v1.2.3