GHSA-vmqq-7qvx-68qx

Suggest an improvement
Source
https://github.com/advisories/GHSA-vmqq-7qvx-68qx
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-vmqq-7qvx-68qx/GHSA-vmqq-7qvx-68qx.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-vmqq-7qvx-68qx
Aliases
  • CVE-2019-10791
Published
2022-05-24T17:09:13Z
Modified
2024-04-22T23:26:36.596782Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
promise-probe OS command injection vulnerability
Details

promise-probe before 0.10.0 allows remote attackers to perform a command injection attack. The file, outputFile and options functions can be controlled by users without any sanitization.

References

Affected packages

npm / promise-probe

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.1.10