GHSA-vp55-fhxx-vcx8

Suggest an improvement
Source
https://github.com/advisories/GHSA-vp55-fhxx-vcx8
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-vp55-fhxx-vcx8/GHSA-vp55-fhxx-vcx8.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-vp55-fhxx-vcx8
Aliases
  • CVE-2020-15777
Published
2022-05-24T17:26:39Z
Modified
2023-11-08T04:02:37.966985Z
Severity
  • 7.8 (High) CVSS_V3 - CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Maven Extension plugin for Gradle Enterprise vulnerable to Deserialization of Untrusted Data
Details

An issue was discovered in the Maven Extension plugin before 1.6 for Gradle Enterprise. It is vulnerable to, in the worst case, Remote Code Execution, and in the general case, local privilege escalation. Internally, the plugin uses a socket connection to send serialized Java objects that are deserialized by a Java standard library ObjectInputStream. This ObjectInputStream was not restricted to a list of trusted classes, thus allowing an attacker to send a malicious deserialization gadget chain to achieve code execution. The socket was not bound exclusively to localhost. The port this socket is assigned to is randomly selected by the JVM and is not intentionally exposed to the public (either by design or documentation).

References

Affected packages

Maven / com.gradle:gradle-enterprise-maven-extension

Package

Name
com.gradle:gradle-enterprise-maven-extension
View open source insights on deps.dev
Purl
pkg:maven/com.gradle/gradle-enterprise-maven-extension

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.6

Affected versions

1.*

1.0
1.0.1
1.0.2
1.0.3
1.0.4
1.0.5
1.0.6
1.0.7
1.0.8
1.1
1.1.1
1.1.2
1.1.3
1.1.4
1.2
1.2.1
1.2.2
1.2.3
1.2.4
1.2.5
1.2.6
1.2.7
1.2.8
1.3
1.3.1
1.3.2
1.3.3
1.3.4
1.3.5
1.3.6
1.4
1.4.1
1.5
1.5.1
1.5.2
1.5.3