GHSA-vpgf-fgm8-gxr2

Suggest an improvement
Source
https://github.com/advisories/GHSA-vpgf-fgm8-gxr2
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/10/GHSA-vpgf-fgm8-gxr2/GHSA-vpgf-fgm8-gxr2.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-vpgf-fgm8-gxr2
Aliases
Published
2022-10-28T12:00:33Z
Modified
2023-11-08T04:08:55.221147Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
Apache DolphinScheduler vulnerable to Path Traversal
Details

Users can read any files by log server, Apache DolphinScheduler users should upgrade to version 2.0.6 or higher.

References

Affected packages

Maven / org.apache.dolphinscheduler:dolphinscheduler

Package

Name
org.apache.dolphinscheduler:dolphinscheduler
View open source insights on deps.dev
Purl
pkg:maven/org.apache.dolphinscheduler/dolphinscheduler

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.0.6

Affected versions

1.*

1.2.0
1.2.1
1.3.0
1.3.1
1.3.2
1.3.3
1.3.4
1.3.5
1.3.6
1.3.7
1.3.8
1.3.9

2.*

2.0.0-alpha
2.0.0
2.0.1
2.0.2
2.0.3
2.0.4
2.0.5